Topic-icon Cronjob Problem

More
06 Dec 2018 16:11 #6558

I solved the issue.

Here my solution for somebody with the same problem.

Problem was, that Vdata have some internal issue, if you check the field for local database within the "Cron/Feed Details". I tried it by unchecking the use of local database and fill in the data of the local database.

Seems that this resolved the problem and all is working fine now. Even after reactivating //server only access.

Would be fine, if there would be a Message for the CronLogs, if something went wrong.

Please Log in or Create an account to join the conversation.

More
06 Dec 2018 15:13 #6557

Fort testing purposes, I tried to change the //server only access by deleting || ($_SERVER != $_SERVER) from controller.php

If i do that, I get the following Errormessage, which ist possibly the answer for the Question.

"ERROR: 0 Cannot instantiate abstract class JDatabaseDriver"

My guess is, that the Cronjob is working but there is no response from Vdata because of some driver conflicts and therefore there is no result to write in the Cron-Logs.

This would maybe explain the 2000+ hits on the affected URL within Cron/Feed.

Have somebody a suggestion to solve the Problem?

Please Log in or Create an account to join the conversation.

More
05 Dec 2018 21:27 #6555

I tried different ways to run a Cronjob to synchronize 2 DBs (wget, curl, even sh script)

I always run the CJs from the same server with the same ip.

I always used the url under "Crond/Feeds" and there are about 108 hits but nothing happend. (import works if i run it manualy)

The last Access-Error-log is:
xx.xx.xx7.243 - - [05/Dec/2018:22:34:01 +0100] "GET /index.php?option=com_vdata&task=set_import&type=xxxxxxx HTTP/1.1" 500 1794 "-" "Wget/1.18 (linux-gnu)"

I dont have a idea what to try next, to get the CronJobs running.

So I now asking for some help... ;)

Last Edit: 05 Dec 2018 21:28 by SG.

Please Log in or Create an account to join the conversation.