Topic-icon Warning: Invalid argument supplied for foreach() in vreview_cb.php

  • Galanopd
  • Galanopd's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
16 Apr 2019 19:46 #6831

Hello,

It looks ok now.
Tested on PHP 7.1.22 so far...
If I don't post again, means all is ok even in higher versions.

Thanks

Please Log in or Create an account to join the conversation.

More
16 Apr 2019 12:24 #6830

Hello,
The issue is resolved, Please download and install the new version.


Thanks
Daniel

Please Log in or Create an account to join the conversation.

  • Galanopd
  • Galanopd's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
16 Apr 2019 00:17 #6828

Ok, it's going to be a long night...

After creating a new profile in vReview and choosing
A. Profile Layout * option: com_comprofiler view: userprofile
B. When I login as a user and click on Vreview tab I get the error shown in the attachment.
C. Inspecting the element in FF I get

1. The script from “ etanee.local:81/index.php/en/?option=com_vreview&task=vreviewjs ” was loaded even though its MIME type (“text/html”) is not a valid JavaScript MIME type.[Learn More] cb-profile
2. Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help xhr.spec.whatwg.org/ jquery.min.js:4:26097

In case you believe that jQuery migration is somehow related please see also

3. JQMIGRATE: Migrate is installed, version 1.4.1 jquery-migrate-1.4.1.min.js:2:542

Thank you

Attachments:

Please Log in or Create an account to join the conversation.

  • Galanopd
  • Galanopd's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
15 Apr 2019 23:02 #6827

Feedback,

It seems that the issue was caused because the vReview profile was not published.
After publishing the demo profile under Component --> Vreview --> Profiles, the errors disappeared.

Thanks

Please Log in or Create an account to join the conversation.

  • Galanopd
  • Galanopd's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
15 Apr 2019 22:43 #6826

Hello,

I am afraid it is not easy to allow backend access as I am working on a wamp server and the error is reproduced in my local environment.

Steps I followed:

1. I have uninstalled every vReview item I had installed and reinstalled the vReview pkg and the cb_plugin again.
2, When the cb_plugin installation finished I received the "constructor" error as seen in the attachment.
3. After publishing the cb_plugin the database error 1064 appeared in the frontend when I logged in as user to access cd-profile.

Thank you

Attachments:

Please Log in or Create an account to join the conversation.

More
15 Apr 2019 10:52 #6825

Hello,
Please share your backend & FTP login credentials via Contact us form along with the Page URL where you have published the vReview module and the link to this support forum thread, we'll look into it.


Thanks
Daniel

Please Log in or Create an account to join the conversation.

  • Galanopd
  • Galanopd's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
09 Apr 2019 15:06 #6814

Moreover, this is what I see in the backend when I install the plugin in the CB ver 2.4.1
By the way, my !Joomla ver is 3.9.4

Attachments:

Please Log in or Create an account to join the conversation.

  • Galanopd
  • Galanopd's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
09 Apr 2019 14:29 #6813

Ok, I understood that 2.9.12 was a typo.
Therefore, I have installed pkg_vreview1.9.12.zip through !Joomla extensions installer and plug_vreview_cb1.0.2.zip through CB plugin management and when I login in CB through the front-end, I get attached messages.

My configuration is

WAMP 3.1.8
MariaDB 10.3.13
PHP 7.2.10 (tried with 7.1.22 too, no luck)
Apache 2.4.39

Attachments:

Please Log in or Create an account to join the conversation.

  • Galanopd
  • Galanopd's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
09 Apr 2019 13:52 #6812

And how am I suppose to download the 2.9.12 version? I can;t find it. Under "My Orders". I can only see the 1.9.12!

Please Log in or Create an account to join the conversation.

More
09 Apr 2019 12:00 #6811

Hello,
The latest version 2.9.12 with the fix is released.


Thanks
Daniel

Please Log in or Create an account to join the conversation.

  • Galanopd
  • Galanopd's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
04 Apr 2019 15:52 #6802

Galanopd wrote: Warning: Invalid argument supplied for foreach() in xxxxxxx.....\components\com_comprofiler\plugin\user\plug_vreviewforcb\vreview_cb.php on line 163

In line 163 we have

$db = JFactory::getDBO();

$users = JFactory::getUser();
$user = $users->id;
$email = $users->email;

$xml = $profile->xml_attribute;
$m = json_decode($xml);
$xmt = array();
foreach($m as $v) {
if($row) {
if(isset($row->$v))
{
$x[$v] = $row->$v;
}
}
}
if(!empty($x)) {
$xmlval = json_encode($x);
}
else {
$xmlval = '';
}

Any ideas?

Also, is there an updated version as this one has deprecated functions in php (missing _construct) as I had to edit php files in order to fix it?

Please Log in or Create an account to join the conversation.

  • Galanopd
  • Galanopd's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
04 Apr 2019 15:49 #6801

Warning: Invalid argument supplied for foreach() in xxxxxxx.....\components\com_comprofiler\plugin\user\plug_vreviewforcb\vreview_cb.php on line 163

In line 163 we have

$db = JFactory::getDBO();

$users = JFactory::getUser();
$user = $users->id;
$email = $users->email;

$xml = $profile->xml_attribute;
$m = json_decode($xml);
$xmt = array();
foreach($m as $v) {
if($row) {
if(isset($row->$v))
{
$x[$v] = $row->$v;
}
}
}
if(!empty($x)) {
$xmlval = json_encode($x);
}
else {
$xmlval = '';
}

Any ideas?

Also, is there an updated version as this one has deprecated functions in php (missing _constructor) as I had to edit php files in order to fix it?

Please Log in or Create an account to join the conversation.